Codidact logo does not display inline

I guess it was fate that my first post on here was a bug report :confused:

As you can see, in the upper-left corner, where the Codidact logo should display is instead the image alt text.


This seems to be caused by the fact that the images are loaded from a non-HTTPS route, whereas the forum is running on HTTPS. The images are blocked on my screen too.

Thanks for the heads-up on this. A cache refresh (ctrl+f5) displays the logo for me but with a warning of insecure content because it is being served over http.

I think we should get force_https enabled again. I’ve asked ArtOfCode in chat about switching how CloudFlare does HTTPS. See their support page if interested.

Per this Meta Discourse post:

Yep, you can’t publish over HTTPS reliably without that [force_https] setting being enabled. It’s why it warns you every time you visit the dashboard that it has to be set.

Quite why it doesn’t attempt to serve the images over HTTPS without that being set, I don’t know. The prevailing wisdom seems to be “enable force_https when you’ve got SSL working” !

Yay. This has been fixed, by setting force_https to true. Maybe you need to force-reload the website (Ctrl+F5) to see the change.


This topic was automatically closed after 84 minutes. New replies are no longer allowed.